alum.app is down temporarily
Incident Report for Alum
Resolved
The alum.app landing page is now back up and running.
Posted 15 days ago. Mar 07, 2019 - 01:30 UTC
Update
We are continuing to investigate this issue.
Posted 15 days ago. Mar 07, 2019 - 00:33 UTC
Investigating
We are currently investigating the issue.
Posted 15 days ago. Mar 07, 2019 - 00:32 UTC
This incident affected: alum.app Landing Page.